Cycleops Magneto & Wahoo Speed


#1

Hello all.

Started out on Trainerroad a couple of months ago having had no previous formal training plans on the bike. Enjoying the structure and intensity (so far)… Did the sprint triathlon base LV and am now half way through SSB1 LV.

Couple of quick questions. I have an old cycleops magneto with a wahoo speed sensor set up with virtual power on my Galaxy S8.

The Speed sensor seems to pop up randomly as one of (or sometimes both of) 2 devices:

  1. Wahoo Speed 58FE - Speed/Cadence sensor
  2. Wahoo Speed - Speed sensor ID #22782

If I can get it to pair with the second it’s far more responsive and updates power almost instantly but more often than not I can only get it to pair with the first which is extremely sluggish and can take 5-10s to ramp up to a change in intensity.

I don’t have any other sensors right now and the phone is enabled for ant+ and bluetooth - Anybody have any idea what’s going on? It’s not a massive issue at the moment but will get annoying when the training turns more to VO2 I think.

Second question - I can’t help but be curious - Anyone made the jump from a magneto on Virtual power to a Power Meter / Smart trainer and know how accurate the power curve is? I know it’s just a number… Doesn’t stop me wondering :slight_smile:

Any input appreciated. Cheers


#2

Hey Sammy!

The reason that there are two ways to pair the sensor is due to the fact that the sensor can pair via both Bluetooth and ANT+.

  1. Wahoo Speed 58FE - Speed/Cadence sensor (Bluetooth)
  2. Wahoo Speed - Speed sensor ID #22782 (ANT+)

For mobile devices, ANT+ updates more quickly than Bluetooth, which explains the issue you’re dealing with. The only problem is that the ANT+ connection can be harder to establish and maintain.

I would recommend disabling Bluetooth during the pairing process, and placing the phone right next to the sensor when trying to establish a connection. This will give you the best chances of a successful pairing.

You can learn how to further optimize your wireless environment by checking out the following link:

In summary:

ANT+
Pros: Faster Refreshing
Cons: Tougher to pair

Bluetooth
Pros: More robust connection
Cons: Slower to update when using mobile

I hope this helps!


#3

Thanks, appreciate the response. Makes sense and I’ll try disabling Bluetooth and see how I get on. Once it’s locked in it doesn’t seem to drop out so hopefully I can get this working for every ride.

So, anyone have any experience with the magneto power accuracy?

Thanks again