Drivo II very slow to change resistance... normal?

trainer

#1

Hey everyone. I’ve got a new Drivo II that has been pretty great, other than the really slow resistance change time. I’ve used a Kickr 2017 and 2018 previously, and it changed resistance for intervals within 1-3 seconds typically.

With my Drivo II, I did a TrainerRoad workout yesterday (Ansel Adams), and going from 102w to 340w took about 11-12 seconds on each of the 24 intervals I did. I created a screenshot comparison of my workout (link below) and someone else’s from an original Drivo I that I found on TrainerRoad for the same workout. The other person’s Drivo I went from 117w to 396w in about 2-3 seconds. I’m also frequently getting dips in power when it’s trying to increase resistance (arrow in screenshot). This could be from me ramping up cadence and it being too aggressive with not wanting to overshoot the power? Given that the Drivo II should be 3x faster than the Drivo I… I’m at a loss.

Is this normal?


#2

PS: The above TrainerRoad ride was done on my iPhone via BLE. But I’ve also done workouts in Zwift using Ant+ and had the same results. At this rate, any workouts with intervals shorter than ~40 seconds will be a total waste. Spanish Needle will be impossible.


#3

I don’t think the comparison to someone else’s ride is a good starting point - there are more things different than the same (trainer, software, connectivity…literally all the things you should test).

I think the normal causes of these delays (I see them sporadically with my setup…maybe one or two times per week) are largely due to either connectivity problems. It’s very hard to troubleshoot this remotely - but getting your device closer to your trainer should be your first attempted resolution. Second would be making sure you have adequate hardware for the TrainerRoad application - if you’re on an older iPhone there could be some processing delays causing the consistent delays.

Next steps would be updating the firmware on the trainer. Running intervals from another application and seeing if you see the same delays (would confirm whether it’s a TR problem or a more generic problem)


#4

I appreciate the response. I know there are a ton of variables at play here. I do feel there’s value in a comparison though; at the very least, it shows that what I’m experiencing is not “normal”, when it’s clear that someone with an older trainer is getting response times 6x faster than me, regardless of the cause.

As I mentioned, I have done TR workouts using BLE from my phone, and Zwift workouts using Ant+ on my computer. Same result for both.

That said, I’m not sure what to do to further test a connectivity issue. I never had this problem with the Kickr that I replaced with this Drivo II; nothing else about my setup changed. I have my phone mounted on my handlerbar, and I can’t really get it any closer to the trainer without having it not visible or accessible. My wireless headphones keep paired to my phone even when I use the bathroom during a trainer session (with the bathroom on another floor).

When using Zwift, I pair the trainer via Ant+ to my computer. I’m using the TacX Ant+ antenna “dongle.” I have the antenna base positioned on the ground, near my front wheel… so about 3-feet from the trainer. I ran Zwiftalizer on my log from yesterday (I run TR and Zwift concurrently, one on BLE, one on Ant+) and it shows RX failures at about 13% for the trainer. Though the trainer wasn’t paired via FE-C controllable, so this isn’t the cause of the slow responsiveness yesterday. There’s no way to test the BLE signal strength failures through TR that I know of.


#5

If you see these delays with every interval do a single interval with your phone not visible or accessible - put it on the ground next to the trainer. See if you get the same behavior


#6

I’ll try that here in a little bit. Assuming that doesn’t change anything, what else could it be? The trainer has never been paired to any other Bluetooth device. Though I guess I could turn Bluetooth off completely on my computer, just for the heck of it. I also made sure no other controllable app was open on my phone (e.g., the Elite app mainly).


#7

Any new ideas what could it be? Have u wrote to elite about it? Ive read on trainerroad.com that guys from here (Chad, Nate) recommended exactly Drivo II and they tested it.


#8

I have contacted Elite support, and their answer (so far) was an explanation of what happens when the controlling device sends a command to the trainer (not helpful) and blaming it on “interference.” I’ve written back to them, no other response yet.

That said, I did a 3 part test today between Elite’s app (with a custom workout created in it), TrainerRoad on iOS, and Zwift on computer with Ant+…

First two intervals with Elite’s app on phone (BLE) with phone on handlerbar. Took 12-13 seconds to go from 100w to 300w. Next three intervals on TrainerRoad app; first one with phone on handlebar, next two with phone next to trainer on ground. All three sets are about 8-10 seconds to go from 102w to 344w (Ansel Adams workout). Next three intervals on Zwift (Macbook Ant+); first with antenna in normal position next to front wheel, next two with antenna pulled farther back toward trainer. Moving it back did improve signal (via Zwiftalizer) but did not improve responsiveness, all 3 intervals took 8-11 seconds.

So no matter how I slice it, with the iPhone in multiple locations, and Ant+ antenna in multiple locations, and 3 different apps… the Drivo II is taking 8+ seconds to adjust from 100w to 300w (and presumably the same or longer for bigger differences).


#9

I have a similar problem with my Turbo Muin Realpower. I have it down to Samsung tablets and their ANT+ chips. They seem to drop consistent connecting when less than 60% charge or you have been doing too much in-between reboots


#10

JamesJ, hmm… I’m not using a Samsung tablet, and my Ant+ antenna is a Tacx USB antenna with a cord and base.


#11

When I can use my Surface with a cable and Ant+ dongle it responds alot quicker. Just need to keep the dongle right near the trainer


#12

It’s not normal. Drivo II is the best trainer product from Elite. It’s not acceptable when it takes few second to change resistance. This or next week I should get my new drivo 2 and can’t wait to check how it will be. Surely will let u know.


#13

I think this is enough information for the Elite customer support to justify a replacement unit. You need to convince them of course, but having tested across multiple devices, multiple applications, and both ANT+ and BLE you are seeing the same behavior regardless of distance from the device to the trainer.

Assuming you have the latest firmware on the trainer there’s not much further troubleshooting you can do - it is almost certainly the trainer


#14

All true, do it and give them(elite) feedback. They should give you replacement trainer.


#15

I was hoping for confirmation from any other Drivo or Drivo II owners. I can return/exchange it from where I purchased, but I’ve done this twice recently after having vibration and noise issues with the Kickr 2018. :frowning:


#16

That seems very slow, i don’t have a Drivo, i have the Elite Directo, it changes much quicker, about 3-4 secs for similar changes. The flagship turbo like yours should be at least equal if not better.


#17

I’ve got my drivo 2 today. Tomorrow Im gonna do workout. Let u know guys how erg mode works with my drivo 2


#18

Yep, I have exactly the same problem. Response is so slow. I tried by ant+. Don’t know what to do


#19

One thing that you can do to speed up the ERG response of a slow-to-respond trainer is to shift into an easier gear (small chainring, large cog) for the duration of your workout. Let me explain how this works:

When using a large gear, there is more inertia (and rotational velocity) in the freewheel. This is a complication that the trainer then has to account for when changing the resistance to meet the ERG command.

If you use an easy gear, the inertia decreases and the freewheel spins slower which allows the trainer to adjust the resistance more reliably.

Go ahead and give this a shot and see if it has a noticable effect :slight_smile:


#20

Hey Bryce, thanks for the reply!

I learned early on when I had a Kickr that the lower gearing worked better and was smoother in holding a particular wattage. That said, I always do my Erg-mode workouts in the small chainring, and typically somewhere in the middle of my 11-32 cassette (usually just find the quietest cog and go with that). I haven’t tried specifically going to the largest 32t cog. I’ll give it a shot tomorrow, but I have my doubts that a few cogs will bring me from 12s down to 3-4s.

Even 12 seconds isn’t really that long of a time span in the grand scheme; especially on longer minutes-long intervals… but now that I’ve been experiencing this resistance delay, I’ve become really aware of just how many TR workouts feature high-power intervals of 30 seconds and shorter.