ERG Mode - am I missing something or doing something wrong?

#1

I am relatively new to smart trainers and ERG mode and can’t help but think I’ve missed something or got something wrong.

I’ve got a Wahoo KICKR Core and pair it up to TR along with my crank power metre but I haven’t been getting on well with ERG mode. To me it seems like the resistance doesn’t change, so to maintain the required watts as they increase I end up having to pedal at a faster cadence or changing up gears. I binned it off and did my workouts in resistance mode, however this morning I did a ramp test in ERG mode and ended up having to change gears and max out my cadence. Is this how it should work?

0 Likes

#2

Probably need powermatch on. Here are some pointers
https://support.trainerroad.com/hc/en-us/search?&query=Powermatch

0 Likes

#3

Hey @edreynolds!

I’m sorry to hear that your ERG mode has not been working smoothly within TrainerRoad :pensive: . I’ve asked a Support Agent to reach out to you via the email associated with your account, and you should hear from them tomorrow morning at the latest :+1:.

They will be able to take a look at your most recent ride to see what exactly went wrong and set you on the path to correct it.

Cheers, and good luck!

3 Likes

#4

Cheers @Bryce, someone contacted me today, I didn’t think it was an issue with TR, more that I’d got something wrong. I’ve had some good recommendations from TR Support and think I’ve got it figured out from the feedback I had from the workout I did today.

Thanks again for the assistance

Ed

1 Like