ERG Mode lag with Bluetooth


#1

I’ve had this happen a few times now. Using a Kickr Snap, with Windows 10 w/bluetooth connection. Was doing Clark this morning and on two of the sprints (12 seconds) the ERG mode took about 10 seconds to kick in, considering I started spinning up about 3 seconds before the interval, I almost spun myself off the trainer hitting a cadence in the mid 120’s. Nothing like expecting a big hit and getting no resistance. I guess ERG isnt good for short sprints, should have gone standard mode. Does anyone else run into this? The trainerroad graphic kinda covers it up and makes it look like you hit the number while Strava shows the real story.


#2

I had the same issue with my 2016 Kickr last fall. I spent a lot of time with Wahoo and TrainerRoad tech support figuring it out, but what probably made the most impact was using a BlueGiga Bluetooth adapter at the end of a USB extender cable and zip tying it underneath the kickr. The other thing I did was to modify my WiFi router settings to “bluetooth coexistance” mode–since bluetooth radio bands can overlap with some of the channels for 2.4GHz WiFi (my router was about 6ft from the trainer direct line of sight).