Help from the Hive. TrainerRoad and wahoo snap are killing me

Before we start I have contacted support and gotten no real help. She has been very nice but nothing we have tried has worked.

The issue. I have a kickr snap wheel on trainer. With a staged power meter. With TR in erg mode it holds the wattage WAY over target. Like my warm up in erg mode this morning was held way over 350 watts for the entire warm up (I bailed and switched out of erg after warmup). I wish I had the FTP to support that but at a 249 ftp it makes for a miserable warm up. I have tried bringing the cadence up, using the beta app, unplugging and resetting the trainer and stopping and letting the trainer reset at zero. I am also in the little front ring and on the bigger side of the rear cassette.

Other issues have come up such as when the power ramps up in the workout it grabs a random much higher wattage and tries to kill me. It seems to hold a high wattage no matter what I do.

Lately because the warmups hurt so bad I have to switch out of erg mode and just do it as a resistance workout.

For reference I don’t have any issue with zwift controlling the resistance when using that app. This seems to be a TR specific

I am at my at the end of my rope with this. My workouts are suffering and it’s a giant pain to switch mid workout. Does anyone have any suggestions?

Two obvious questions (support will have asked you this too, but it’s missing above). Are you using powermatch? And do you calibrate your power meter?

1 Like

Yes I am using powermatch and yes the power meter has been calibrated.

Maybe try and run a spin down calibration, through the wahoo app, on the kickr snap. It might help, might not. Also use the wahoo app to make sure the snap has the proper firmware update. Back when I used the snap, it would act all sorts of weird if it wasn’t up to date.

2 Likes

Bluetooth or ant+? Is it possible that you have more than one device with bluetooth or ant+ connected at the same time that is sending resistance data to your trainer? Like, do you have wahoo open on your phone whilst trainerroading from a computer?

1 Like

+1 on this. Last time I had similar issues I had to you’re the firmware on the wahoo and it was a real pain. Calibration had to be done through their app and things just didn’t make sense no matter what I tried. I’d tinker more with the wahoo functions.

2 Likes

When I first got my Kickr Snap 2 years ago I had similar problems, dropouts and ridiculously high wattage resistances in erg mode.

The solution was incredibly simple (thank you TR support), since which I’ve used it in erg mode with TR for two whole years with not a single problem.

The solution? Use only Ant+, disable Bluetooth.

For the record I’m quite low-tech: no power meter, only an android phone, the snap and a Garmin HR strap and cadence sensor. Offline, Ant+ only.

Also, I do a spindown calibration every workout but just use the TR app version, not the Wahoo app. I’ve never had an issue.

1 Like

I had trouble with ERG mode when I had a snap…most likely you have some interfering connections…only run TR, no zwift or wahoo app and see what happens and only connect with ANT+.

I’d also suggest a test with the trainer only connected (no power meter) to see if the behavior is the same or different.

1 Like

Just for reference I have done the spindown in both the wahoo and the TR app. I have done one both before and during the workouts with no change.

I am using an iPad that’s not connected to anything but Bluetooth and the house Wifi. I have deleted the wahoo app from it just in case there was anything going on in the background between the two apps. I will see what that does on tomorrow’s workout.

I think the next logical step is to try to connect with ANT+. I will have to order a dongle as the iPad doesn’t support it natively. Anyone got any recommendations for a particular brand?

I am also going to try to use virtual power and ignore the power meter and see what happens. That is definitely sub optimal but it would at least tell me something if it worked.

I am going to try these things one at a time and see what happens.

1 Like

For clarity, that is not “VirtualPower”. VirtualPoweris ONLY for non-smart trainers using a speed sensor to estimate a power value.

You are getting a real power value from the Snap, it’s just from a trainer rather than a power meter. This test of the trainer-only power eliminates PowerMatch from the variables to make a more simplified test.

Note, that any discrepancy between the power meter and trainer will result in altered effects on your body from the higher or lower power data. I recommend a simple and short test with something like this workout for a super fast evaluation:

That’s the plan is to just try it and rule that out or not. I don’t want to do a whole workout using the snap’s power. I can just swap to resistance mode and hold the power myself until I work it out.

1 Like

I have had mostly smooth 3 years with two different snaps. My first one had issues causing drops in power. Fixed with a firmware update.

Then it seemed every other workout the snap would over shoot on warm up by alot. It would either sort itself out in a few minutes or sometimes it seemed like dramatically increasing/decreasing intensity +/- button would have it “Catch”. Odd.

I have also noticed that chainring/cog selection matters on the snap in its ability to hit low recovery/warm up power. With my old one, if I was in big chainring it couldn’t get wattage down low enough / fast enough.

I also use a stages PM now, and don’t use powermatch. Rather I go in the wahoo app and select control snap with ANT+ and use the stages. Then in TR I select the snap. I am honestly not exactly sure how it all works, but it does. It has been 2 years of using that way.

Not sure if any of these are helpful, but wanted to share. While I have had great experiences for a long time, those times when it didn’t work right drove me nuts, so I feel for you!

2 Likes

I was struggling to get my wife’s SNAP working well until I tried to “pair” the SNAP with her powertap. Once I went into the app and entered the ANT+ ID of her powertap things have worked really well for her. I never had to teach her how to perform the spindown calibration nor do I frequently mess with the tension or tire pressure. Just need to make sure the powertap is calibrated and add some air to the tire once in awhile.

2 Likes

Glad to hear! My experience as well. I calibrate the stages each time before hopping on. And have gotten good at finding the right wheel pressure and tension (about 5-5.5 1/2 turns).

So strange, I have the same Kickr Snap and Stages PM setup and use ERG mode. I don’t have any problems at all. I haven’t calibrated the Snap in about a year (of course I calibrate my Stages PM before each ride).

I guess that’s not at all helpful!

I did some testing and changes today to no avail. I did get some changes but not for the better. Eliminated any stray Bluetooth signals and tried workouts on two different devices. The first was an iPad the second was my iPhone.

The changes that occurred were rather than just holding power until my tongue was in the spokes it would hold power and then release and hold way under power. The power file looks like a roller coaster from start until I threw in the towel.

Tomorrow I will rule out the power meter and try using the internal meter in the snap. After that I will give the control over to the Snaps via ant+ as suggested above.

1 Like

I like the idea of power match and I think it’s a valuable tool, but I haven’t made it past initial stages of a workout to use it because I’ve been consistently annoyed by the variance that it naturally causes in concert with a Kickr Snap. I think the wheel on solution doesn’t work well with power match because of the delay in cadence changes, power meter readings, and other similar variables. Now, I never even turn on anything but my Snap via Bluetooth and the TR app on my iPhone/iPad when inside. I have consistent numbers when I ride outside, so ultimately I use only trainer power for indoor and adjust to “feel” outside with my power meter, which is generally right on 3-4% higher than my kickr power.

Sorry, I don’t have any solutions to offer that you haven’t already tried, but I do have the exact same problem! Hoping someone here knows how to fix it. The only thing I’ve noticed is that if I quit the workout, unplug the Kickr, and restart several times, it eventually goes away or becomes manageable.