Kickr core firmware update-failure anyone else getting this fault?




My new just out of the box kickr core is failing to go to firmware 1.06 from 1.02.

Has anyone else had this issue?

I’ve not had the best luck with wahoo support in the past.




I’m not sure what troubleshooting steps you’ve tried but I would try these first

  • Keep the device you’re updating from as close to the KICKR as possible while updating
  • Make sure the Wahoo app is up to date
  • Reboot the mobile device you’re updating from
  • Try a different mobile device if possible

I would also check that the ANT+ ID and serial number match up between the app and what it says on the side of the KICKR.

I went from 1.0.4 to 1.0.6 without any update failures but i’m unsure about going from 1.0.2 directly to 1.0.6.


Thanks. Seemed to be restarting Bluetooth has done it a treat.

You’ve got me into my session. Many thanks.


I ran into this issue today. Couldn’t get the flash to work using my Google Pixel 2 no matter what I tried. As a last resort I dug out an old Amazon Kindle and the flash worked fine.