Kickr frustrations

trainer

#1

I tried doing some searching for this, but couldn’t come up with anything. If this is has been brought up before, my apologies and bear with me here:

Anyway - I have I think a gen 2 kickr - has the newer handle. Everything has been fine with this unit as I’ve had it for about 4 months. I’m using it in erg mode with workouts and power smoothing enabled on the wahoo app. I either use my duo trap for cadence or my stages. Up until recently, my stages wasn’t working, so why I was just using the kickr.

However, this past week all of my workouts feel like hell. I’ve done spin downs, advanced spin downs, trainer road spin downs, and tightening up the belt - but not too tight. I just had to quit Glassy because for whatever reason 180 watts for five minutes felt like 300 watts. I have an sneaky feeling this is why my ramp test on Tuesday felt horrible.

So, I just paired the stages as my power source and the kickr just for resistance/erg with power match on. Again, felt like shit.

I did mount field on Thurs and felt fine. Yesterday I couldn’t finish my workout either. Getting my cadence over 85 was torture where in the past I do these threshold workouts at 90-95 cadence.

Is it my trainer? Am I burnt out? I’ve raced a lot this spring, summer, and fall for cx. Have sort of been taking it easy the last week and a half and got right back into my 2019 training Tuesday.

I reached out to Wahoo and now just waiting to hear back.
My stages is up to date. My kickr is up to date.


#2

Have you tried using erg on the KICKR and stages separately with another head unit or phone, etc. to see if the power is close between the stages and KICKR for the workouts (would be unlikely that both are on the fritz, so a comparison might be a good first step) before moving to physiological causes?


#3

Agreed that running the trainer and PM on 2 devices for a quick side-by-side comparison is a great test.


#4

@mcneese.chad @Lawrence That was my first thought and I forgot to mention. Had the stages app open and then the kickr power source just for trainerroad and they were pretty close. I just did another test using zwift and stages app - numbers were close.
I’ll find my garmin and try again tomorrow AM with a free ride spin or something - it’s an off day with my plan, but I think just some light pedaling should be okay to test this out.

Thank you so much for hearing out my frustrations and replying.


#5

Make sure to test at varied resistance levels. A match at 100w is no guarantee of a match at 200w or 300w.


#6

Every time something like that happened to me it was because two apps were both trying to control the Kickr.

Not clear if you are using computer or phone, sounds like a phone. Bluetooth? ANT+?

It’s easy to not force quit apps on your phone. I even had a problem recently where Wahoo app was in background taking control of TickrX heart rate monitor and stopping TrainerRoad from using it.


#7

Silly question, maybe, but you haven’t changed your gearing recently have you? I mean that if you decided to start using a lower gear (to better replicate CX type terrain) you would get precisely the effect you describe.


#8

I do use my phone as my MacBook doesn’t have bluetooth 4.0. Could be it - maybe I had the wahoo app still running in the background. I’ll double check before today’s test ride.


#9

Hey Man, I used to have similar issues but on the opposite spectrum, on erg mode 300watts would feel like 150watts. I always run my p1 and kickr at the same time so it didn’t take me long to find out the gap in the power.
Long story short, wahoo couldn’t figure out what was going on and they had my trainer replaced. Kudos to wahoo for great customer support.
Since that, I try to make sure that there’s no other bluetooth device running in the room because as others said it could happen that you have two devices connected to the trainer, even a bluetooth headphone.
My current set up is wired headphone connected to my phone, p1 streaming via ant+ to watch and kickr via bluetooth to iPad and it works w/o issues.

Cheers

Ronaldo


#10

A few more thoughts and ideas:

  1. The dual-fight-for-control usually occurs when you have 1 app connected on Bluetooth and another on Ant+

  2. I believe only the in-use app has bluetooth priority on iOS. The background app can not access the bluetooth except in dedicated channels like headphone audio.

  3. Another easy test is to run one app on your phone (TR, Virtugo, Zwift) , and a different app on your laptop (Zwift, Kurt, TR) via Ant+. Set up one app as the MASTER control and the second to monitor the power output using Virtual power. Check the numbers that way. Virtual power will be calculated via wheel speed and cadence so it will not be taken form the Kickr. Good enough to determine if the values are off.

  4. Are you training alone with one device in the house? Make sure your partner didn’t accidentally pair your Kickr to their set-up while they are training.

Mik.


#11

I think so too. What happened to me was a different, the Wahoo background app will try connecting to TickrX to download any stored data. So it grabbed my HRM before I launched TR app, thereby blocking it.

Also agree with you about dual fight-for-control, its only happened to me when one app was using ANT+ and the other app was using Bluetooth.


#12

These are all great thoughts. Thank you.

My setup, which has been fine till this week - well, have noticed a few days maybe a couple of weeks ago where I felt like the workouts were too much but decided it was due to the stress of racing and doing hard workouts for four weeks straight.
-Iphone
-TR on iphone
-kickr connected via BT to iPhone
-tickr
-duo trap cadence to iPhone/TR

The only other thing I can think of, was earlier in the week switching it up and using my stages as the power source and kickr for resistance/erg mode. Maybe I had the wahoo app running after my spin down on tuesday and didn’t close it. Hell, maybe I had zwift companion open too.

EDIT: I’m going to use my garmin with ant+ to my stages and kickr to BT to trainer road and do some spinning and see what happens. Should I take the kickr out of erg mode for this? Yesterday I did a bit of this and the stages was doing normal readings - up and down and but were all in 5-10 watts of what Trainerroad was saying during my 180-190 watt erg mode interval. I mean, I could hold the power, but was struggling with the cadence. Like I said earlier, was hovering around 75-85 where normally I can those workouts 85-95 no problem.


#13

I know someone else mentioned it, and you’ve probably already checked, but this happened to me a few weeks ago, and it was the Stages talking to my ELEMNT which had grabbed control of the trainer. SO basically the app was showing say 100 watts but the ELEMENT was saying 300 watts. It took me a while to figure out what was happening.


#14

Hi! I had issues with my Kickr Snap with Erg mode and the resistance being way too hard for an interval - I had to put out 300 watts for a 220 watt interval for 45 seconds before the trainer would ease off. There was significant lag in the resistance changes. My firmware was up to date as well. This was also with a left-side Stages Power meter.

Old setup:

  • power match in TR disabled
  • control with Ant+ in Wahoo app: enabled
  • power smoothing in Wahoo app: enabled
  • running TR on iPhone
  • used big gear ring up front

I tried a bunch of different settings and then did an advanced spin down which seemed to help. With the new settings, Erg mode is now useable:

New setup:

  • power match in TR enabled (auto)
  • control with Ant+ in Wahoo app: disabled
  • power smoothing in Wahoo app: disabled
  • running TR on iPhone
  • used small gear ring up front

With this new setup, the lag seems to have gone but my output power deviates slightly around the target. From a TR support page this seems to be expected as my average output power for the interval matches the target. I also try not to chase the power target and rather try spinning at a consistent output. Hope this helps, I was quite frustrated for several days too. I am interested in your solution, so post it when you have figured it out.


#15

OK. Just finished Ericson. For the warmup and first sweet spot 2-3 min effort of the warmup, everything felt like crap like usual. But, once I hit the recovery before the first of four eight minute intervals, that feeling went away and everything sort of felt like it used to last week.

This is what I did:
Garmin 500 synched with Stages and tickr
Iphone : synched with Kickr as powersource, duo trap for cadence, ticks
Wahoo app: power and speed simulation off, power with stages off
TrainerRoad: power match off. Erg mode on.
With all of this - the power on the stages was pretty consistent with what the kickr was doing. Not exactly spot on, but 5-10 watts here and there.

I was able to do the SS intervals at 85-90 cadence and the last minute was only when I dipped below 85 and the last interval was below 80 and struggling. But, with an IF of .8 and TSS of only 65, I was a bit confused on the last effort. But, all in all I think things might be back to normal.
Will do another spin down tomorrow on TR before Taku.

All of this could just be mental and I am doing mid volume instead of low volume like I did while racing CX (short power build). Most of those workouts weren’t exactly as ‘hard’ as I was maintaining fitness and staying fresh for weekend races.

Onward


#16

I just came across this “Advanced Factory Spindown” calibration article.
Did you already cover this?

M.


#17

Oh yeah - spend down, advanced spin down, trainer road spin down

Going to clean my already clean drive train and make sure everything is square.


#18

Maybe I’ll give power match a try too during today’s Taku ride.


#19

I hear ya!! The first 2 weeks getting my Kickr it drove me crazy. My 320FTP own power meter sessions were not achievable on the kickr. After re-doing a FTP test using the kickr only, the difference was 50 watts. Knowing this number made me feel like I wasn’t going crazy.