Not sure if ERG mode is working on 2014 Kickr (firmware is up to date)?

trainer
#1

I bought a second hand 2014 Kickr from a friend yesterday (he’s very trustworthy so I don’t believe the trainer is broken) and I’m not convinced that ERG mode is working but I’m a smart trainer newb so i might be wrong. I think it might not be working because when I did a ramp test yesterday the only way I was able to increase the power seemed to be by spinning faster and changing up gears. I ended up on my big ring (46) and 11 tooth sprocket with a cadence of 100 and was making about 270w. If i reduced cadence the power dropped off. Is there a way of telling whether or not ERG mode is working or not?

I have checked the firmware version and it’s up to date and I have ERG mode set in the TrainerRoad app on my laptop. I don’t have a power meter on my bike and I had I have Power Match set to Auto. I read that the device shouldn’t be paired with any other apps so perhaps I should remove it from the Wahoo app on my phone but this seems odd because the TrainerRoad app is connecting to the Kickr and sensing speed and power from it. Any suggestions?

0 Likes

#2

Read and check these articles:

0 Likes

#3

Thanks very much. I’d already read the first one and the only thing I can see different in my setup is that the screenshot shows Power Match set at Disabled rather than Auto, so I’ll try that. Is the way to test if ERG mode is working to:

  1. Enter a workout
  2. Select a cadence and wait a few seconds to see if the Kickr adjusts to the goal power level?
  3. Change cadence and then wait a few seconds to see if the Kickr adjusts to the goal power level?
0 Likes

#4

Yup, your list is the right way to test. Make absolutely certain that you have ERG mode selected (visible at the bottom of the screen for PC/Mac, or in the trainer settings under Devices on the mobile app).

Run the workout, hold a given cadence and be patient to allow the trainer time to adjust. Can be 5-10 seconds depending on the change in power target.

Pedal as absolutely steady at your desired cadence as you can to let it stabilize. Then you should change cadence an see if the trainer follows with a resistance adjustment.

0 Likes

#5

I’ve just performed the following steps:

  • Taken my Garmin Ant+ cadence sensor off my bike and noticed that the Kickr isn’t providing a cadence reading. The TR app on my Mac was using my Garmin Ant+ cadence sensor but now it’s not getting a reading.
  • Removed the Kickr as a sensor in the Wahoo iOS app.
  • Shut off bluetooth on my Mac and fired up the iOS TR app. I found that in the iOS app that it was NOT in ERG mode despite it being shown as ERG mode on the Mac app when it was connected. I switched it to ERG mode in the iOS app.
  • Hopped on and started a workout and it was immediately clear that ERG mode is now working but cadence is still not being reported.

Questions:

  • Is there any configuration that I need to do to get cadence to work? The only thing related I saw was a setting in the Wahoo app about taking cadence from Ant+ but I’m not sure if this is relevant.
  • Is it possible that there’s an issue with the TR Mac app?
0 Likes

#6
  1. There is no cadence provided directly from the Kickr (regardless of BLE or ANT+).

    • You must add a separate cadence sensor to the crank if you want cadence data.
  2. The Mac app in general is working. But we have seen one or more people with issues.

0 Likes

#7

Ah - that’s interesting. Not sure if it’s a dumb question but there’s a field for cadence next to speed and power for the Kickr, does that get populated only if you have a Wahoo cadence sensor perhaps? I’ll just pop my Garmin cadence sensor back on and i think I’ll be good to go by the sounds of it.

0 Likes

#8

I don’t think that will ever show as filled. That is simply there as standard formatting since other trainers offer that data (CycleOps and Tacx units in particular).

If you add a cadence sensor, it will be shown and displayed as a separate device and data field.

0 Likes

#9

I’m with you. I have to say I’m blown away by the high quality of TR support on the forum - AWESOME! Thanks so much for getting me going. Although darn it - now I need to go redo the ramp test i think - perhaps this time it won’t sound like the Kickr is about to take off and head into orbit now that i won’t be peddling at very high cadence in my top gear :slight_smile:

1 Like

#10

Happy to have you here. There are some really smart, and very helpful people here (TR and non-TR).

I’d say it’s rare that a problem goes unsolved and it’s great to see when people get up and running the way they want to go.

Happy training :smiley:

1 Like

#11

Oooooffff - I just did Reinstein. Hot damn ERG mode is AWESOME. It hurt like crazy but i got through it. Loved not having to mess about with gears and cadence. Thanks for your support getting me up and running!! :smiley::smiley::smiley::smiley:

2 Likes