Power resistance stopped during workout with Tacx Neo Smart trainer

power-issues

#1

Hi guys,

I’m using TrainerRoad without issues since february, but the last few weeks I have powerresistance issues during a workout. After aprox. 25 min the powerresistance stop working during the workout. The smart trainer stays connected and displays the power but there is no change of resistance anymore.

I had this the last 5 workouts I ride.
The Tacx Neo Smart has the latest firmware updat e an there are no issues on the Tacx testing dashboard in the Tacx App.

This is my equipement:

  • Windows 10 tablet 32 bit with the latest updates and the TrainerRoad app
  • Tacx ANT+ dongle
  • Tacx Neo Smart trainer

Are there other people who have this problem?


#2

Your problem sounds different that anything I’ve encountered. You might try a new ANT+ dongle.

My Neo throws in an occasional period of extra resistance for maybe 2 tenths of a second, mostly when in resistance mode. It isn’t enough to affect my workout, but enough to annoy me and make me worry about the health of my Neo.

When I first started using my Neo and TR, the workouts would sometimes start with no resistance (Windows 10, Intel i7 laptop). Restarting the TR app would fix it. I figured it might be a (slow) mobile Internet network problem with getting everything loaded into the app. These days I give the app plenty of time to get started and don’t start Firefox until I’m into the workout.

A third problem I’ve had is with the TR app locking up and leaving me struggling at a permanently high resistance setting. It was as if the app was waiting for a signal from the Neo, the USB driver or the Windows clock. I would have to kill the app through the Windows Task Manager and start the workout over. I haven’t encountered this lately. Maybe Windows or the app got fixed.


#3

The first thing I’d recommend is using the Tacx app to update to the latest version of the software. This can sort out a lot of quirky trainer related issues.

If that doesn’t work, I’d recommend reaching out to our Support Team at support@trainerroad.com if you haven’t already. They will be able to look into your log files to see if this is an issue with your trainer or with TrainerRoad.

Best of luck!


#4

I have the latest firmware on my Neo. Checked with the Tacx app.


#5

Do you have the possibility to test a workout on an iPhone with bluetooth smart ? i have a Neo and run my workouts on my phone over bluetooth and have no issues . Maybe this way you can see the ANT+ dongle is faulty before buying a new one ?


#6

during the execution of the training do you leave the application? I train with the App on Android, and when I leave the app to watch a message it is as if the neo disconnected from Ant +


#7

@Thomas_De_Kesel: I could try it with my Android Phone with bluetooth as a test, but I have an other ANT+ dongle (from Garmin) to test it.

@nemomaya: No, I don’t touch the tablet and it stays on the TrainerRoad app in fullscreen while riding.

I didn’t calibrate the Neo but normally this isn’t necessary with the Neo (and I worked well till 2 weeks ago).
Today I saw there was an update of the Windows app. You never know it is fixed…


#8

Had same problem 3 weeks back, app on Android phone, elite smart trainer and stages. All devices showing connected but lost resistance at trainer. Happened two nights in a row but then has worked fine ever since. Not sure what “fixed” the problem unless an update had happened on app