Power trace with Garmin 2s/Kickr Core - Is this normal?


#1

Hi

This is the power trace from my Tunnabora workout this morning.

I was using a Garmin 2s to measure power, an up to date iPhone with a Wahoo ant+ key, the lastest version of the TR app, and a new Kickr Core with the firmware update. I had TR set up with automatic powermatch. I calibrated the PM and did a spin down on the Kickr, but reported as successful.

The power recorded doesn’t seem to have tracked the TR prescribed power very closely at all, but as this was the first time I have used a smart trainer I am not sure if this is normal or not. Can anyone tell me?

I plan on doing my next workout without the Garmin PM connected, just using the Kickr and TR for control, to see what result I get.

Edit: Erg control also seemed to drop away briefly in the first and third intervals, I was only putting out 140W when the workout was calling for 180W. This corrected itself.

Any help appreciated!

Thanks
Chris


#2

My stages look like this on power match, when I just use the trainers power it seems to follow much closer to the prescribed work. I don’t know whether it is a function of where the power is measured? Pedals, cranks bit more spikey compared to a smoother hub measure as in the smart trainer.

Maybe someone with a bit more power meter experience could help here


#3

Most trainers tend to artificially smooth the power compared to a strain gauge based PM so this is expected


#4

This is a factor of how your trainer measures power vs how your pedals measure power.

In general the power meters all give multiple readings per second and as such will fluctuate more significantly (closer to your foot the higher the fluctuation) whereas the electronic trainers are measuring resistance based on momentum and tend to be significantly smoother.

Unless you have a strong desire to see the line be perfectly flat there is no reason to use anything other than power match with your setup.

As for erg mode dropping - there are two common causes for this. One is that you actually have two devices trying to control the trainer (i.e. the wahoo app and your TR session on your iPad) or you have the device controlling the trainer a bit too far away from it. Both are easily remedied. Close other apps for the first one and get closer to the trainer for the second (I use my laptop to run TR and have a USB extension cable to drop my ant+ dongle down to sit right next to the trainer


#5

@slowtrier first thing to understand is that your Kickr Core also has fluctuating power, you just can’t see it by default.

Wahoo artificially reports “smooth power.” In other words, the Kickr records power fluctuations, but “lies” and reports an artificially smooth power.

You can see this for yourself, go into Wahoo Fitness app, select Sensors, select your Kickr Core, and disable “ERG Mode Power Smoothing.” Then use any app and you’ll see the actual power recorded by your Kickr Core.