Ramp Test in Erg mode with PowerMatch


#1

I tried doing the ramp test with my power meter (quarq dzero) controlling my Wahoo kickr 2 and powermatch and erg mode enabled but my power seems to be higher than the trainerroad ramp, which is messing with my head. I just gave up, felt like I was working too hard too early. Any advice?

Note, I calibrated both PM and Wahoo before the test and after spinning the wahoo for at least 10 min.


#2

Your ride data is set to private, so we can’t see your workout.


#3

Updated. I didn’t even know there was such a setting.


#4

Ya, there does look to be a lot of power variation there. Not just the Ramp Test though, it seems like thats normal for your TR workouts going back to the end of Sep. I guess that’s when you got or started using your PM. You’re not going to just perfectly hug the target power, but you seem to be getting around ±20%, which I think is too high. Something is going on here. I would recommend a ticket to support@trainerroad.com and see if they can’t help you try to improve things.


#5

I think something is wrong with your power meter. Your cadence numbers are jumping all over the place in all of your recent rides. (Presumably you’re tracking cadence from the quarq). Assuming this is the case it is causing significant power reading jumps from the power meter which the trainer is attempting to chase.

Zooming in on a few random spots in your rides I see second-to-second cadence jumps that are all over the place

91->101->92->97 (four consecutive second readings from within your ramp test)
104->95->102 (three consecutive second readings from within the first other ride I clicked on Flinders - 1)

Either you’ve got a crazy inconsistent cadence style (hard to imagine it changing that much that quickly) or something is wrong with your power meter and it is causing all of these problems

I did randomly check one of your outdoor rides and did not see this cadence behavior - but I didn’t look in a bunch of places to confirm - so maybe something about your indoor setup is messing with how the quarq is calculating cadence


#6

Thanks for taking a look at my files and it seems you are spot on on my cadence being all over the place:

About my setup: When riding indoor, I do use a Wahoo Cadence mounted on my right shoe (on bluetooth like the rest of the devices). The device is enabled in TrainerRoad as well. Could it be causing interference? For some reason that detail got out of my mind.


#7

Why use the Wahoo Cadence sensor? Use cadence from the Quarq.


#8

I just removed it from my setup - I didn’t realize the quarq had a built in cadence meter. I will try the test again tonight and post an update on the cadence reading.


#9

To calculate Power, a powermeter must measure cadence. Power = Torque x Cadence

I think you will find your problem will be solved.


#10

Wahoo Kickr by itself must do something different. I am currently running just the Kickr without a cadence sensor. (I have run it with a cadence sensor too).


#11

Just do a FreeRide until you get your setup down. No point going all in on another Ramp Test if the results are bogus.


#12

Cadence is irrelevant. What matters is the presence or absence of a 2nd power data source for PowerMatch to use and adjust to in the process.

Removing that 2nd power meter simplifies the whole picture and makes for less overall variability, because it eliminates PowerMatch.


#13

That’s fair. For the longuest time I tried to stay away from powermatch but dind’t like having to use Kickr only FTP power value for outdoor rides with a PM.


#14

Sounds good!


#15

I just tried the freeride with the Wahoo cadence sensor removed and the cadence read by the PM tracks very well :slight_smile: Thanks for all the help!