Signals keep dropping out

windows
ant

#1

Hello all. I have had this issue on going for a long time. It has finally gotten to the point where I need to try to resolve it.

The issue I am having is that during any workout the signals keeps dropping out for both my power meter and heartrate strap. Also before I had the power meter I used virtual power with a Garmin speed/cadence sensor. I experienced the same issues with those devices. I would be doing a workout and without warning the signal for the PM or HR would drop out, sometimes both. This causes the TR workout would just stop, this seems to happen randomly and last 10 to 20 seconds before picking back up again.

This is very frustrating, but I can’t do a workout. I’ll be in the middle of a tough interval and look up and TR is not even recording…

I use a ACER laptop I bought specifically for my TR workouts. I use this laptop for TR workouts only. There are no other programs loaded on it other than Windows 10. I do not even surf the web with this laptop. I bought this laptop about 2 years ago.

I have a Quarq Elsa Power Meter and a Garmin Premium HR strap.

Things I have done to try a solve this issue;

  1. I checked to be sure all drivers are up to date.
  2. Checked to be sure the laptop is on high power mode. The lap top is plugged in at all times. I never go on battery power.
  3. I have put new batteries in all my devices.
  4. I have positioned the laptop as close to the bike as I can and still be able to see the display. It is on a stool less than a inch from the front wheel.
  5. I have tried rebooting the laptop many times.
  6. My bike and trainer are located in a room I converted into a workout room. There are no other wi-fi devices located in this room.

Does anyone have any thoughts as to what the problem is?

Thanks all.


#2

Not a guaranteed fix, but something like the below can make a world of difference - I’d recommend anyone using ant+ from a laptop use something like this so they can drop the dongle down to be right next to the devices while still seeing their screen


#3

You don’t mention if your Wi-Fi signal is 5G or not. The 5G signal is recommended (Nate mentioned this in a podcast awhile back) as there is little to no interference from things like microwaves, etc. I was having similar issues intermittently and I can share from experience that using the 5G signal made the difference.


#4

My router is dual band, using both 2g and 5g, I can double check which it is using when I get home. Thanks for the tip. I guess I do not understand why it would make a difference? The PM and HR strap are using a ANT+ to communicate with the laptop, not wi-fi.


#5

I would advise buying an ANT+ dongle if your devices support it. I have had similar issues connecting to a laptop via Bluetooth. My iPhone works with no issues over Bluetooth though.


#6

I can try relocating the ANT+ dongle, but if I relocate the ANT+ dongle close to the PM, presumably under the bike it will in fact be farther away from the HR strap than it is currently. But at this point am am willing to try anything.

Yes, I am using a ANT+ dongle plugged into the USB port


#7

There’s a good summary on the support site:

The 2.4GHz band is very crowded. It can be your own router that’s blocking it (even if you are connected via 5GHz, it will keep broadcasting on 2.4GHz unless you turn it off) or your neighbours’ router(s). Even if they are not in the same room, you may be subject to someone else blocking the same frequency band. Some routers have a frequency scanner that show you which bands are used by other participants.

It can also be that your own laptop interferes with the dongle. If the dongle is plugged directly into the laptop like a USB stick, noise from the laptop may interfere with the reception. Using a dongle on a cable can resolve the issue.

Likewise, moving it too close to the trainer may saturate the antenna or subject it noise coming from the trainer. Shuffling things around and trying to eliminate other sources on the 2.4GHz band should solve it.


#8

:clap: Everything the community has suggested so far are great troubleshooting tips! Y’all are on it!

@xcaliber501, Support has always had good luck with both the USB extension cable and changing WiFi router channels.

If you’re still having dropouts after exploring those troubleshooting options, send us an email at support@trainerroad.com, and we’ll look into things more deeply.


#9

Another culprit might be Garmin express running on the pc or any other app that uses the dongle


#10

I have had good luck with a usb extension to relocate the ant+ dongle to my seat post waterbottle cage as it is right next to the pm and also close to the HR strap. Also, you can/should disable auto pause so that if/when the power drops you can continue the workout and just have slightly less accurate data.

Finally, on my Mac I’ve found that if it keeps dropping for no reason, unplugging and reconnecting the dongle can sometimes make a big improvement. I’ve had this go from a power loss every minute or two down to only one time for the rest of the workout,.


#11

Thanks for the replies all. As I mentioned in my OP, this laptop is used exclusively for TR. there are no other apps or programs even installed onto the laptop, not even a web browser. (Except IE which i found to difficult to uninstall)

I have ordered a USB dongle extension cable. I will try that out when it get in on Friday/Saturday.


#12

Turn the power right down on your wifi router. It’s very possible that it’s drowning out the ANT+ signal.

I had this problem in my garage and had to switch out my new wireless AP for a crap old one with a tiny antenna and a low power setting. Instantly solved the problem.


#13

The biggest thing you can do is get the ant+ stick away from the chassis of the laptop. There’s all sorts of interference there that will cause drop outs, WiFi cards, speakers, other USB ports. Getting it closer to the trainer with an extension cable will hopefully solve all your problems!


#14

Hello all. I wanted to give an update. Looks like I have solved the signal dropout issue. Did a test ride last night and TR worked flawlessly. Thanks to everyone for your suggestions. Here are the things I did;

  1. Over the weekend I got in a extender cable and relocated the ANT+ dongle to under the bike seat and away from my lap top.

  2. I found out my laptop did not have a 5 GHz compatible network adapter. I purchased an USB Net Adapter dongle upgrade and then switched the WiFi connection from 2.4GHZ to 5GHZ

  3. I found that my router had a firmware upgrade that needed to be installed.

Not sure if just one of these items was the problem or if all of them played a part, but my problem seems to be solved now. Thanks again everyone.