Speed based on Cadence (not Power)

trainer

#1

Disclaimer: Alright let me start by saying that know that speed is completely irrelevant when it comes to indoor training… All that matters is the tangible stuff like power, HR, cadence.

Alright on to the issue:
I’ve noticed that most of the time my speed (as reported on Garmin/TrainingPeaks) seems to align perfectly to my cadence (like perfectly, perfectly–the same line in TP) and not based on my power. And then occasionally it seems to be based on my power.

I’m wondering if any one has experienced something similar. Additionally, I’d like to know why does it do this and if there is any way to make it more consistent. Ideally, (as irrelevant as it may be) I’d rather have it based on power.

Here’s my setup:
Mac Desktop (w/ ANT+), Wahoo KICKR, Wahoo/Garmin Cadence (makes no difference).


#2

The Wahoo Kickr by default does not report speed based on power. I believe it reports speed based on flywheel speed (using data from the optical sensor that measures power). So if you use a small chainring and middle of cassette, your speed will be less than if you shift into big chainring (because at same power your flywheel is spinning faster in larger gear).

There is a setting “ERG Mode Speed Simulation” you can setup in the Wahoo Fitness app, and I’ve seen it do a pretty good job at providing TR with more accurate speed. Details:

However in conversations with Wahoo support, they do NOT support use of Speed Simulation by 3rd parties. Also, I’ve seen that setting get reset after doing a spindown in TR.

Finally, ERG Mode Speed Simulation does not appear to be working for me since I upgraded Kickr 2017 firmware last week. I’ve used the app several times to disable and enable, and still I seem to be getting flywheel based speed estimates. The firmware I’m now using is v3.4.67 - 27 June 2018… I might try downgrading to 3.3.61, because Speed Simulation was working for me with that firmware. Details:


#3

Thanks for the detailed answer! Did you try downgrading?


#4

@coryherold Never had a chance to downgrade, but your in luck I’m in the garage working on home projects and just downgraded.

If you haven’t done that before, here is how on iPhone:

  • open Wahoo Fitness app
  • tap Sensors
  • tap your Wahoo Kickr
  • tap the Kickr icon 5 times quickly
  • that opens a Select Firmware screen, choose 3.3.61 and downgrade
  • follow the prompt to disable/enable Bluetooth on your iPhone, and then power cycle Kickr
  • open Wahoo Fitness app and review Kickr settings for smoothing (I use off), speed sim (on), and wheel size

I’m now on 3.3.61 and will report back within a couple days.


#5

Good news! Ran a couple trials this morning on the current firmware 3.4.67 and achieved speed based on power in latest version of TR.

Pre-test setup:
Open Wahoo Fitness app
Toggle Erg Mode Speed Simulation off, then on
Perform Spindown in app
Close Wahoo Fitness app

TrainerRoad setup:
MacBook Pro
Ant+ USB Senor
Auto-sync turned off (manually added to dropbox, then Garmin Connect)
Adams -1 (@75%) warm-up only (~5 mins)

Test #1
Wahoo KICKR paired
Wahoo TICKR paired

Test #2
Wahoo KICKR paired
Wahoo TICKR paired
Wahoo Cadence paired

Test #3
Wahoo KICKR paired
Wahoo TICKR paired
Wahoo Cadence paired
Favero Assioma Duo paired

All 3 tests achieved speed based on the power values and did not seem to follow the cadence!


#6

I’ve enabled and disabled Erg Speed Sim in the Wahoo app (v3.4.67) multiple times, in an attempt to resolve and it hasn’t worked since upgrading from 3.3.61 to 3.4.67.

Another example from my last workout (Gibbs aerobic endurance):
Erg%20Speed%20Sim%20and%20Gibbs

Speeds are clearly rpm based, where 92rpm at -11W results in faster speed than 91rpm at 172W. Based on that, the cadence increment is 0.2mph/rpm. That is confirmed when looking at the two 172W efforts, that differ 0.6mph (= 3 rpm * 0.2mph/rpm).

Flat line speed reported in ramp test on Sept 24:


#7

Yeah, that’s frustrating. Here are the captures from Training Peak with a Test yesterday (no calibration) and this morning (with calibration).

No calibration - Yesterday


Speed (green) follows Cadence (yellow).

Calibration - Today


Definitely more in line with Power (pink).

Have you tried turning TR ride auto-sync off? I transferred the ride manually to Dropbox and then imported to Connect (which auto-syncs with Training Peaks).

I have a Ramp Test scheduled for tomorrow morning; hopefully these results will replicate. But based on my track record, I’m not super optimistic.


#8

Yup, your second ride chart looks good.

I’m an engineer and pretty handy with hardware and software, tried just about everything. A few notes in passing:

  • even with 3.4.67 the Erg Speed Sim setting wasn’t reliably reporting power-based speed to TR
  • doing a Kickr spindown in TR app will reset Erg Speed Sim to disabled
  • the Erg Speed Sim setting often resets to disabled while only using Wahoo app
  • I reported “reset to disabled” to Wahoo support and they only officially support Erg Speed Sim with Wahoo app.

I’m kinda done with Wahoo over this wacky “we sorta implemented it but are too busy adding power meters to fix it” state of this setting.

Doing another ramp test today on 3.4.67 firmware, will report back tonight or tomorrow.


#9

I have a Kickr Core on the latest firmware, it seems to work fine for me (although to be fair I haven’t ever really cared about speed on the trainer)


#10

Thanks for sharing your experience! Yeah, yours looks to be correct. Are you running a cadence sensor or just the KICKR Core? And I’m with you on the don’t really care about the speed… For me it’s more of an OCD, I paid this money so it should work right issue. But who know’s maybe we stumble across a workaround, or the developers take note and fix it.


#11

My Kickr has been really stubborn, either the setting works or it doesn’t.

Really odd.

At a basic level I agree - speed on the trainer doesn’t matter. That is why I mostly ignore it. However I do sync to Strava and occasionally cross reference Strava Training Log to try and spot trends. Most of my outside rides are in flat area, so the speed /mileage estimates are a little high but make for a rough equivalence. The engineer in me wants to see it working, so I’m giving it another chance.


#12

I get cadence from my power meter, so I have a Kickr Core running Power Match with my P1 pedals which provide power and cadence information


#13

Speed looked to be okay on my Ramp Test this morning.
RampTest


#14

Another ramp test night, this time on the downgraded Kickr 2017 firmware 3.3.61, and another massive fail with speed based on cadence (not power). Going to upgrade Kickr firmware again. Sigh.

The “Erg Speed Sim” setting has not worked for me since upgrading to 3.4.67 a few months ago.


#15

Kickr now reporting power based speeds!

Last night before workout I upgraded Kickr firmware back to 3.4.67. Low and behold, this time Erd Speed Sim setting actually worked. Not sure what happened a couple of months ago after upgrading to 3.4.67…


#16

That’s awesome! I had success on two rides this week and then it stopped on the third. I’m a bit baffled as the firmware hadn’t changed. The only difference I could think of was that I calibrated the trainer in the Wahoo app for my first ride and then left it plugged in overnight for my next ride. Once finished, I then unplugged it and then did not re-calibrate before for my third. Perhaps turning it off resets the setting. Who knows!?


#17

Setting is flaky. Wahoo only supports with Wahoo app.


#18

I’m going with your theory, and that you need to launch Wahoo app to turn it back on.

So far that is working. Last 2 workouts I did the following:

  • plug in Kickr and spin pedals to wake up Stages PM
  • jumped on bike
  • fired up Wahoo app and started a workout
  • force quit Wahoo app
  • launch TrainerRoad app

And now I’m getting power-based speed data recorded in TR app.

As an aside, I only discovered this because I enabled “Control w/ ANT+ power meter” and wanted to confirm its working before launch TR app.