Tacx Neo not in ERG-mode


#1

Hello everyone,

I have just connected my new Tacx Neo but can’t seem to get it to accept ERG-mode. Am i missing something??.

Regards
DrJ


#2

What device are you using to run TR?


#3

Hello, not sure i understand. I am trying to connect my new tax Neo to TrainerRoad. TR says ERG-mode, but the power is erratic and depending on my cadence. In ERG-mode the cadence is not supposed to affect the power…

Regards
DrJ


#4

Is something else (e.g. the Tacx untility app) trying to control the trainer? Whatever controls the trainer first tends to hog it. Try turning everything off and on again and then just connect with TR


#5

Are you running TR on your phone or PC?


#6

Thanks for the advice. Nothing else is connected and TR can find and pair the Neo. Do i need to do some initial calibration?. This is an option in TR, but nothing happens when i try to calibrate…


#7

I was just wondering which device you use because you may be locking out the BLE connection if you access the trainer with another app before TrainerRoad.

@pirnie has the right idea.


#8

Macbook pro…


#9

Check the Tacx Utility app, any update available at the moment?


#10

Have not installed the app yet. Will do in the near future and check…


#11

Have you ever connected another app or device to the neo? When this happens it doesn’t stop you connecting. TR can still read power, it just can’t control erg mode


#12

@DrJ So you’ve never done a firmware update since getting your Neo?

I’m pretty sure that’s what your issue is if I’m reading you right :slight_smile:


#13

I unpacked my Neo today, so no, i have not done a firmware upgrade yet. Do you do that via the Tax app?.
I did a few minutes of “Carter” and my power was fluctuating 10-30% around my target power. With some short fluctuations 100% above target. It seems to fluctuate around target, so probably following ERGmode.
My earlier Wahoo Kickr was spot-on with only very few and small fluctuations when shifting cadence. The Neo is very erratic, but probably following ERG-mode. Am i missing something on a setting??
Will try to upload pictures from TR.


#14

Sorry about the file size…

Tacs NEO
Wahoo Kickr

Is this right???


#15

Oh it’s a new one. Is it the very latest model? If it is it may not need a firmware update yet. Either way, need to check ASAP!

Search the App store for Tax Utility and the rest will become apparent. It’s a very simple app, doesn’t do much other than check for updates really :slight_smile:


#16

Note that the Wahoo Kickr defaults to using a VERY smoothed power output in ERG mode. You can (and probably should) turn that feature off. It presents a false and unnatural expectation about how we generate power.


#17

I’ve got some bad news for the OP…your Kickr is lying to you.


#18

That’s why I mentioned it and shared the video that shows the huge difference with the setting changed.


#19

OK, that probably explains a lot. But really??, look at the pictures above, is this real??
Maybe it is…


#20

Did you stop pedaling for about 15 seconds at around the 6minutes or is that a dropped signal?

Tiffany