The weight field must be a number

Hi,

why is it not possible to change weight with smaller increment than kilo?

Comma and dot separator give error, both, but different errors. This behaviour was forever, never ‘filed a bug’ on this before.

thanks,
Peter @dkmj

Try inputting using Pounds, then switch your display preference to Kg. Might work?

Sadly, does not work. Input whole pounds. Switch back to metric, and weight is converted to decimal, but one cannot save with this new value.

Ought to be a simple fix for the programmers though. input parsing, there is code out there.

thanks,
Peter at 86.5kg :slight_smile:

Works fine for me…

FTP

Weird. Works for me.
Maybe try entering the values on your phone instead of computer. See if it translates.

inputting in the app (iOS) gives even more weird error. I enter 86,7. there is no ‘save’ button so after a reload, my weight is shown as 867kgs :slight_smile: clearly on the unhealthy side.

2 Likes

also, tried both safari och firefox on the computer, #doesnotwork. seems this is really an input parsing issue. or a mix of language settings.

programmers should (hm) separate language encoding from day one, but i understand this adds a few minutes to the initial workload. ascii does not work outside US.

Contact support.

1 Like

Hey Peter, are you by chance using a Swedish keyboard?

We currently have a bug where a period on the Swedish (Svenska) keyboard isn’t recognized as a decimal on our site. For some reason, the Swedish period isn’t a “culturally aware” one for some reason. This can lead to errors when inputting weight on the website or in the app.

Entering a comma as a decimal separator using the English code page will also trigger a “The field Weight must be a number.” We have this bug in the backlog of issues to fix, but our developers are currently working on other tasks. You might be able to get around this by switching your region and language to English (I had to restart my computer to get the changes to stick for Swedish), and then try to change your weight and add a decimal with this keyboard applied.

Yeah, but if you get your FTP up to 3500W, you’ll be a BEAST. Might need to commit to a high volume plan for that, though.

1 Like

Yes. Using Swedish keyboard. That’s the bug.

Behavior is correct on the iPad. I managed to edit there just now.

Thanks,
Peter

1 Like