TR Workouts not reporting speed or distance to Strava, even with a speed sensor

workout-sync

#1

The last block of workouts I’ve done on TR are not reporting speed or distance to Strava. Anyone having the same issue? I know that the two metrics are irrelevant when it comes to indoor workouts, but I still like to track them.


#2

Hey Juan!

I would double check that your speed sensor is reporting speed properly. It is pretty common for the magnets to get jostled, leading to a lack of speed readings. To check that everything is set up properly:

  1. Go to your Devices Tab
  2. Ensure that your Speed Sensor is paired
  3. Pedal your bike to get the back wheel moving
  4. You should see a speed show up on the Speed/Cadence tile
  • If the Speed Reads as 0, the sensor is paired properly, but the magnet is not registering with the sensor
  • If the Speeds reads as an actual speed, but you still receive a “0” distance in Strava, then you may need to reach out to our Support Team. They can be reached at support@trainerroad.com and they will be happy to help you sort out this issue :slight_smile:

Cheers!


#3

Thank you for the reply, I will try the recommended fix.


#5

I’ve got a similar issue. TrainerRoad on my kickr core delivers laughably short distances for the effort i put in. A little over half of what id expect. Is there a setting in either trainerroad och wahoo fitness app that I should be changing to get more reasonable numbers? I do calibrate the core, it is in the latest firmware, i have power smootiing off.

Cheers,
Peter


#6

Put it in a different gear. The whole issue with ‘distance’ on a trainer in erg mode is that it means nothing, it’s is purely down to your gear ratio (unless you use a virtual cycling app which translates w/kg to speed based on the course profile).

Focus on TSS indoors and out.


#7

That’s funny. I’ve had the opposite problem, fighting with TR settings and sensors to record ZERO speed/distance to the ride data despite the Kickr sending imagined speed/distance numbers embedded in the power data.

I had it working briefly with a magnet speed sensor and wheel circumference set to 0, but this trick stopped working when I went back to the usual magnetless speed sensor.

In the end, I gave up and just record with a Garmin not connected to the Kickr or speed sensor and got my clean indoor files to export everywhere else. All I really lose are the lap splits :man_shrugging: