Two Questions on Favero Assioma Pedals

Hey everyone,

I recently bought a new pair of Favero Assioma Duos and have two, hopefully quick, questions:

  1. I read up about powermatch prior to using and expected there to be a variation between the power (in terms of smoothness) between the pedals reading and the kickr core, but have been surprised by the amount of variation (40-50 watts from target power during an interval, or about an 8 watt difference in the interval target average). Just curious if this is normal behavior or if I am doing something wrong. I’ve included images of my previous three workouts below.

  2. Do both pedals connect to trainerroad automatically? I assume so, but today noticed that my left pedal had significantly less battery charge than the right, and was wondering if this had something to do with a lack of connection?

Thanks!

Your graphs looks pretty similar to mine using a similar Assioma/Kickr18 setup with power match. The variation is relative to how smooth you are at delivering the power and your selected cadence. I think of it as trying to cancel out a wave - if you stay consistent the software has a better chance to correct.

I don’t know about both pedals - that might change depending on Ant+/Bluetooth connection type. It is discussed here: which might have some more information.

https://forum.trainerroad.com/t/favero-assioma-duo/13562/8?u=jdv

you graph looks all over the place compared to mine. I have the duo and Tacx vortex smart, using powermatch and assioma controlling the power. no issues tbh.

are you keeping your cadence as controlled as possible?

Within the Assioma mobile app, make sure your pedals are using the ‘Unified Channel L’ setting.

I was having similar power variability issues and this seemed to make a big difference. If your pedals are set to ‘Dual Channel L/R’ and you’re using Bluetooth, then I think TR has to double the data from the Left pedal which I’m guessing causes issues with power match.

2 Likes

interesting. I have never touched that setting (in fact, don’t even know what setting is on now), and I have never used TR with bluetooth. it’s on when I use the assioma app to calibrate, and I turn it off when i get into TR app.

Thanks everyone!

Cadence does range a bit, but not by a ton (generally between 85-90)

Confirmed that “Unified Channel L” is selected in the application.

Other thoughts? It may be that I just need to work on producing steady pressure to the pedals. In the grand scheme of things a difference of 8 watts on an interval probably wont make or break me, but I guess I thought it would be closer. For example, today there were 5 to 10 second periods where I was doing an interval at 268 watts where my power was reading at 230 watts.

that’s not right. who is controlling the trainer? kickr or assioma?
it is definitely not a normal behavior.

Kickr is set to Auto, which I understand automatically enables power match when the Assioma is connected.

I also just bought a pair of the Favero pedals and am having a similar issue with the Kickr and Powermatch, I assumed it was normal but given peoples responses not sure now. Anyone else having this problem?

Edit: to make clear that I am real person.

I’ve used my Assioma pedals with power match with both a Kickr 17 and a Tacx neo 2. The previously shown graphs are typical for the amt of smoothing with the neo much smoother. I recommend doing a factory spin down with your kickr. Mine is within 10 watts of my pedals after having done so.

Thanks very much everyone, it seems I am not the only person that is experiencing this variability in the readings.

I have a similar setup to you and experienced similar issues when I transitioned from just the Kickr (2017 Snap) to the Kickr with Favero Duo. At first I thought there was an issue with PowerMatch or something wrong with the equipment, but I could never figure out what was wrong. So I really focused on keeping steady cadence and applying smooth power through the pedal stroke. Ultimately, I came to the conclusion that the power smoothing on the Kickr just really obscures your actual power output and lets you get away with pretty bad form.

Take a look at these two workouts, one from September of last year (when I made the switch), and the same workout from last weekend. My cadence and power output is much smoother.

Perhaps, unlike me, you really are experiencing a technical issue. Who knows? However, I found that focusing on my cadence and pedal stroke, while ignoring the power number, made the biggest difference.

Good luck.

1 Like

I am having similar problems, specifically

  1. Constant power dropouts - At no point during the below workout did I stop pedalling however the power dropped frequently to 0, auto paused the workout for a faction of a second, then gradually made its way back up to the actual power reading
  2. Extremely erratic power readings - for the most part there was no discernible difference in effort or certainly not the kind of effort that would amount to +/- 50 watt power fluctuations
  3. At a few points for a fraction of a second the trainer would apply a large amount of additional resistance for no reason

I am using
Assioma Duo running 4.04 firmware on Unified Channel L mode
iOS App Version 2019.10.1.89613
Tacx Bushido running 3.1.22 firmware

Hoping someone is able to help

Capture

powermatch on or off? Which device is sending cadence…? that looks ok. Any chance your phone/tablet could be having trouble keeping up or is it managing too many bluetooth connections?

I suggest getting in touch with TR Support directly, they can usually look at your log files to see if there are connection drop-outs or other technical issues.

Thanks for your response

Powermatch is on and I believe the pedals are sending cadence, there are only 3 devices connected to my phone so it shouldn’t be a problem, that said I don’t really know anything about the Bluetooth protocol

I’ll have another fiddle around in the morning and if it is still a problem i’ll raise a ticket and see what they say

Cheers

I went back and forth with support for a while on this with no definitive resolution – though they said that they were working on an update for powermatch to try and correct this issue. In the meantime, they recommended that I just use the trainer to control the power, since my Kickr and pedals were reading within a few watts of each other.

As others have suggested, it does help to try and keep your cadence and pressure to the pedals as smooth as possible. This results in the trainer trying to “self-correct” less which leads to smoother power.

That said, even when I do that I find that the intervals can still be off by 3-5 watts. For example, when using the pedals and powermatch an interval target at 280 watts might end up with an average of 276. Despite this, like you mentioned I never really felt a difference in the resistance level, so I am not sure it actually has much of an impact on the training benefit.

Let me know if you hear anything different from the support squad.

1 Like

Newbie with the pedals… how do you know the pedals are using bluetooth or ANT+ to transmit numbers? In the app, I can’t tell which protocol is being used? I prefer bluetooth but I am all ears as to suggestions… thought Dual L/R channel would be the best option to select but after reading this it seems that you use the unified L channel even though you’re using duo pedals?

Thanks in advance.

In bluetooth mode, Dual L/R channel means dual pedals send signals out individually, and Unified L channel means both pedal signals will only be sent via left side, just like Ant+ does. This is a constraint by app side (as well as hardware) which decides how many bluetooth channel booked for power meter. As most of apps treat power data comes from single source(device), only one channel of bluetooth is required.

1 Like

Do you know if TR legitimately connect dual L/R on the assiomas or just a doubling of the left when in that mode?

When in unified mode the power from both channels is combined and sent. TR can not be doubling left only power because it is not being broadcast independently :+1: