Using Entertainment with TrainerRoad


#1

Apologies if I’ve missed this in other forum threads, or on the FB pages.

I’ve tried the TR Support instructions on the webpage shown above, but cannot get other video media to playback in full screen mode with TR workout minimised at the bottom, or top, of the screen.

I’m using a recent Laptop with Windows 10 and running MS Edge.

Whenever I try to overlay the TR workout it takes whatever full screen media is playing, YouTube, Eurosport player, Facebook Live [GCN Cyclocross coverage] and reverts to the normal “general” display.

The same happens is I open TR first and then the video, or the video first and then TR.

I work around by resizing the Edge page, or in some media, using Cinema mode, both of which increases the size of the video whilst letting the TR workout fit onscreen simultaneously, again either top or bottom of the display.

Sorry again if the answer’s obvious, but any advice appreciated.

Thanks


#2

Hey there! Sorry to hear this is happening to you, but luckily I have a simple fix.

When you mentioned that any full-screen media would cover the TR “Minimal Mode” window, I was worried there was a bug with your version of the app. However, I realized you’re watching YouTube, Eurosport, and Facebook Live all on the Microsoft Edge browser.

I know it’s the “recommended browser” on Windows, but it’s hardly better than Internet Explorer as far as these things go. :wink: Fun fact, we’ve actually discontinued support/testing for the Microsoft built-in browsers because of the constant issues we’ve had and the small user base of those options.

I tested this on my own laptop using Microsoft Edge and verified that any full-screen media will cover up the TR window. The fix is easy - just download a modern, supported browser like Google Chrome or Mozilla Firefox and you should be able to watch all the entertainment you want, in full-screen. Cheers!


#3

Larry, thank you for picking this up. It’s much appreciated I’ll switch to another browser - cheers.
Update: Changed browser, tested and problem solved. Just to note though, I’ve had no success with the shortcut mentioned on the support page - press F for fullscreen - although again, it’s prob’ly user error. Ta.


#4

It does make you wonder why MS continue pushing the Edge - nobody seems to use it by default bar @Ti-Buron of course


#5

I’m actually haviong trouble with this still. On MacBook Pro, using Chrome. F for fullscreen just goes to fullscreen and no sign of the minimized workout.

Does Chrome need to be minimized before pressing F??

Thanks in advance


#6

On Mac, we’d recommend using Firefox for your fullscreen entertainment. Other browsers, including Chrome, open a different display when you fullscreen them, and this ends up overlapping the TR window. Hope this helps!


#7

Good call, M$ is killing Edge, they’re be building a new browser with the Chrome engine.

If anyone values their privacy, don’t use Chrome (the Google version), use Chromium, or Brave, or Firefox instead.


#9

Hi Larry, this worked for me (using Firefox), but I would like to know whether you have plans to enable TR to run “minimized” on an iPad, as this would be more convenient for me. Thanks!


#10

I’d love something like this. Running the main TR app as ‘master’ on the laptop because it has the Ant+ dongle. And then a controller (mini) remote app on phone / iPad which doesn’t have Ant+, but to control things or show a specific page of field data (customizable). Since you are on the same wifi it could talk over that .


#11

We don’t have plans for this at the moment, sorry! :disappointed:


#12

Ok thanks. Just a little bit of a pain to run TR on iphone and Neflix on iPad or borrow the bf’s laptop!

Josée Olivier

jo_mtl2002@hotmail.com