Watteam Powerbeat

power-meter

#21

Same here. To say I’m annoyed is an understatement…


#22

Have any of you had your Powerbeat start flashing red? I can’t connect to it at all. I hoped it was just because it needed to be recharged, but that did not help :frowning:


#23

Mine worked yesterday. Although it is still in ANT+ mode thank goodness.
All their social media has disappeared too. I hope someone buys them out soon.


#24

So If I just bougt a single watteam powerbeat G2 on ebay without refunds there´s no way I can´t use it? I can complete the app registration, any ideas? someone knows how to download an older version for ios so I can complete the registration and use my powermet??


#25

I certainly wouldn’t risk it! I already own one and cannot get it to connect to the app, in any shape or form.
Save up for a Stages or similar.


#26

try again I got a new phone and the app didn’t work for a while. its working now


#27

I got the app to activate but now it won’t connect to the Powerbeats. Hope this is a step in the right direction though.


#28

Can you file a class action against a company that’s closed down?


#29

Me too. I tried after seeing your post.
I’m not sure I want to try and connect to the unit! It’s so hit and miss, I’m scared it’ll get stuck on BLE and then not be able to get back to ANT+!